vRA 7.x erreur Request to vCO failed. Error: 404

de | 26 avril 2020

Au niveau des logs vRA je rencontre cette erreur :
Request to vCO failed. Error: 404 , Azure:VirtualMachine not found, An error occurred while getting workflow.

Si on regarde plus en détail dans le fichier :
/var/log/vmware/vcac/catalina.out

[UTC:2020-04-26 09:59:45,617 Local:2020-04-26 09:59:45,617] vcac: [component="cafe:advanced-designer" priority="ERROR" thread="tomcat-http--36" tenant="vsphere.local" context="PY0PV7uK" parent="PY0PV7uK" token="6SqLQQkg"] com.vmware.vcac.designer.service.vco.VcoService.getO11nGwWorkflowById:144 - An error occurred while getting workflow with id '1fb71eae-c04f-42a5-8ebd-f4e0acd5f9aa'. Cause: '404 '
org.springframework.web.client.HttpClientErrorException: 404

J’ai également cet erreur :

[UTC:2020-04-26 09:59:25,527 Local:2020-04-26 09:59:25,527] vcac: [component="cafe:advanced-designer" priority="ERROR" thread="advanced-designer-service-mainTaskExecutor13" tenant="" context="" parent="" token=""] com.vmware.vcac.designer.contentmanagement.init.ContentImportInitializationTask.handleOperationInfo:215 - Import XaaS content into CMS: 20-azure-content-xaas.zip [dry run/OVERWRITE] FAILED errorCode=85105, message=85105-A vRO type with type id Azure:VirtualMachine not found

Le problème provient un d’un workflow non trouvé à priori.

Pour retrouver le workflow j’ai cherché dans la base postgres avec l’id dans la table “vmo_workflow” . Il s’agit d’un workflow pour Azure , Restart Virtual Machine.

Après recherche il manque le plugin Azure, voir pouvez trouver le KB ici :

https://kb.vmware.com/s/article/55826

L’erreur à disparu des logs.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.